Get in touch
Back
Maintenance

Server updates

Completed 21 Dec at 10:40am MST.

AzNate's Tech Website AzNate's Roads Website
Completed

Maintenance completed

Posted 21 Dec at 10:40am MST.
Started

Web server will be undergoing update maintenance for a short period of time.

Posted 21 Dec at 10:20am MST.