Get in touch
Back
Maintenance

Server upgrades

Completed 13 Jan at 05:00pm MST.

AzNate's Tech Website AzNate's Roads Website
Completed

Maintenance completed

Posted 13 Jan at 05:00pm MST.
Started

The server will be undergoing hardware upgrades during the specified time. Therefore, the AzNate websites will be unavailable for a while.

Posted 11 Jan at 04:45pm MST.