Get in touch
Back
Maintenance

Server updates

Completed 13 Jan at 09:35pm MST.

AzNate's Tech Website AzNate's Roads Website
Completed

Maintenance completed

Posted 13 Jan at 09:35pm MST.
Started

Software updates will be applied to this server during this time. Consequently, the AzNate websites will be unavailable for a short time.

Posted 13 Jan at 08:29pm MST.