Get in touch
Back
Maintenance

Server updates

Completed 19 Feb at 08:30am MST.

AzNate's Tech Website AzNate's Roads Website
Completed

Maintenance completed

Posted 19 Feb at 08:30am MST.
Started

Installing server updates once again. The websites may be temporarily unavailable for a short time while the server is restarted.

Posted 19 Feb at 08:00am MST.