Get in touch
Back
Maintenance

Server updates

Completed 17 Apr at 03:45pm MST.

AzNate's Tech Website AzNate's Roads Website
Completed

Maintenance completed

Posted 17 Apr at 03:45pm MST.
Started

The website server will be undergoing software updates for a bit. This will result in a short period of downtime.

Posted 17 Apr at 03:25pm MST.