Get in touch
Back
Maintenance

Server updates

Completed 20 May at 08:15pm MST.

AzNate's Tech Website AzNate's Roads Website
Completed

Maintenance completed

Posted 20 May at 08:15pm MST.
Started

Server updates will be installed shortly, so expect a short downtime.

Posted 20 May at 07:40pm MST.