Get in touch
Back
Maintenance

Network maintenance

Completed 19 Aug at 06:44pm MST.

AzNate's Tech Website AzNate's Roads Website
Completed

Network maintenance and server updates finished!

Posted 19 Aug at 06:44pm MST.
Started

The websites will be temporarily down for a short time for network maintenance.

Posted 19 Aug at 06:00pm MST.