Back to overview
Maintenance

Server updates

May 20 at 11:35am MST  –  May 20 at 11:50am MST
Affected services
AzNate's Tech Website
AzNate's Roads Website
AzNate's Transit Website

Resolved
May 20 at 11:50am MST

Server updates finished

Created
May 20 at 11:35am MST

Server updates will be performed today. Expect a little downtime.